Fone de ouvido não desabilita alto-falante

Estava com um problema um pouco chato em meu laptop, que não desabilitava o alto-falante quando eu conectava o meu fone de ouvido. Googlando por headset+speaker+ubuntu, encontrei um link, que deu uma boa dica:


$ sudo echo options snd-hda-intel model=laptop >> /etc/modprobe.d/alsa-base

Atualização em 19/05/2009: eu estou usando Ubuntu 8.10 em um laptop Itautec N8620, fiz o que está acima e não obtive sucesso. Procurando por mais informações, percebi que o comando nem sempre resolve. A partir de [1], fiz os seguintes passos:

1) Executei o seguinte comando [0]:

$ sudo head -n 1 /proc/asound/card0/codec*
==> /proc/asound/card0/codec#0 < ==
Codec: Realtek ALC882

==> /proc/asound/card0/codec#1 < ==
Codec: Motorola Si3054

2) Abri o arquivo ALSA-Configuration.txt:

$ cd /usr/share/doc/alsa-base/driver
$ zless ALSA-Configuration.txt.gz

3) Procurei por “ACL882″ e encontrei as linhas:

...
        ALC882/885
          3stack-dig    3-jack with SPDIF I/O
          6stack-dig    6-jack digital with SPDIF I/O
...

4) Alterei o arquivo alsa-base, incluindo ou alterando a linha:

$ nano /etc/modprobe.d/alsa-base
...
options snd-hda-intel model=3stack-dig

5) Reiniciei meu laptop

6) No controle de volume do laptop apareceu uma opção “Surround”. Percebi também que a opção “Front” estava funcionando. Assim, para desabilitar o alto-falante e habilitar o fone de ouvido, basta desabilitar a opção “Front” e aumentar o valor da opção “Surround”, conforme figura:

controle-de-volume

O documento [2] parece ser interessante para saber mais sobre o problema.

[0] http://ubuntuforums.org/showthread.php?t=806620

[1] http://ubuntuforum-br.org/index.php?topic=42448.0

[2] https://help.ubuntu.com/community/HdaIntelSoundHowto

Sobre Marcelo Akira

Professor de redes e tecnologias educacionais
Esta entrada foi publicada em Software Livre e marcada com a tag , , , , , . Adicione o link permanente aos seus favoritos.

Uma resposta a Fone de ouvido não desabilita alto-falante

  1. rafael disse:

    Basta DESMARCAR a opção : controle de volume-> chaves -> headfones

    aki funcionou…

    abs!

Deixe uma resposta

O seu endereço de email não será publicado Campos obrigatórios são marcados *

Você pode usar estas tags e atributos de HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>